Tools/Operators

There are tools that help with editing the traffic system. They can be found in the 3D Viewport Select and Object menu.

Select Curves

menu:
3D View => Select => Traffic => Select Curves

This tool selects all curves that are part of the active traffic system.

Select Connectors

menu:
3D View => Select => Traffic => Select Connectors

This tool selects all connectors that are part of the active traffic system.

Select Dead Ends

menu:
3D View => Select => Traffic => Select Dead Ends

This tool detects dead ends of the active traffic system. These dead ends (connectors) will be selected and the number of detected dead ends will be reported.

Note

After executing this operator the traffic system will be deselected.

Remove From Traffic System

menu:
3D View => Object => Traffic => Remove From Traffic System

This tool will remove selected curves from the traffic system.

Note

When deleting a traffic system without removing the curves first the traffic system isn’t actually removed from the scene. It is just not visible. This is default behavior of Blender.

If you want to remove a traffic system from the scene you need to make sure that it doesn’t have any references to the system.

With the Remove From Traffic System you can make sure that the reference from a curve is removed.

Validate

menu:
3D View => Object => Traffic => Validate

This tool validates the active traffic system.

When working with a large traffic system it is easy to get lost. This tool warns about what is missing in the traffic system.

When done it shows a dialog with the found issues. This tool does not make any changes to the scene.

Fix Dead Ends

menu:
3D View => Object => Traffic => Fix Dead Ends

Try to fix dead ends of the active traffic system.

When importing OSM models some dead-ends are created as OSM doesn’t split the curves in a way the traffic system can handle. This operation helps by detecting most common cases so less dead-ends needs to be solved manually.

The dead ends that will be solved are connectors that are within 1 blender unit of any curve point. When that is detected the curve-spline will be spliced into two separate splines.

  1. Traffic System with dead ends.
../../_images/operator-fix-dead-ends-before.png
  1. After fixing dead ends
../../_images/operator-fix-dead-ends-after.png

The curve from left to right has a control point at the location where the dead-end is detected. The curve is split into two splines at this point. Both splines are still part of the same curve.

This operation can also be used on regular Bezier Curves.

Clean Up Traffic System

menu:
3D View => Object => Traffic => Clean Up Traffic System

Tries to fix issues when the internal data of the traffic system becomes invalid. In normal situation you won’t need to use this operation as the tool enforces that the traffic system is consistent at all times.

This tool is kept for just-in-case situations.

Refresh Traffic System

menu:
3D View => Object => Traffic => Refresh Traffic System

Regenerate the traffic system.

You can still make changes to curves after they have been added to a traffic system. These changes might not be visible in the 3D Viewport. This operation will update the traffic system with the latest changes that have been made to the curve so the 3D Viewport will be updated.

Note

When simulating, data of the curves are used directly. This operation just updates the visual representation in the 3D Viewport.